Time Entry exports are back to normal.
A time entry export (PDF/XLSX/CSV) or PDF attached to an invoice that was created between Aug 05 11:20 and Aug 06 10:30 may have missing time entries and incorrect section totals.
Time entries matching the following criteria were omitted from exports:
Time entries linked to a reference that was imported from Jira, without a label attached.
The following time entries would not have been affected, and would still show in exports as expected
Time entries without references
Time entries with references created via the Browser Extension, or otherwise not auto-imported from Jira
Time entries auto-imported from Jira with at least one Label defined in Jira.
We recommend re-exporting and/or reattaching the relevant time entry exports that were created in this timeframe.
Technical Explanation
A reference search optimization designed to increase performance when searching for references with labels triggered a unknown to us bug in our database engine's query parser that resulted in references without labels (but with metadata from a Jira import) being removed from the result set.
Reference joining logic in the export then failed, resulting in the time entry rows being skipped and omitted from group totals.
Resolved
Time Entry exports are back to normal.
A time entry export (PDF/XLSX/CSV) or PDF attached to an invoice that was created between Aug 05 11:20 and Aug 06 10:30 may have missing time entries and incorrect section totals.
Time entries matching the following criteria were omitted from exports:
Time entries linked to a reference that was imported from Jira, without a label attached.
The following time entries would not have been affected, and would still show in exports as expected
Time entries without references
Time entries with references created via the Browser Extension, or otherwise not auto-imported from Jira
Time entries auto-imported from Jira with at least one Label defined in Jira.
We recommend re-exporting and/or reattaching the relevant time entry exports that were created in this timeframe.
Technical Explanation
A reference search optimization designed to increase performance when searching for references with labels triggered a unknown to us bug in our database engine's query parser that resulted in references without labels (but with metadata from a Jira import) being removed from the result set.
Reference joining logic in the export then failed, resulting in the time entry rows being skipped and omitted from group totals.
Identified
Time Entry Exports, including those associated with invoices that were sent to 3rd party billing providers, were missing time entry line items when the time entry was associated with a Reference that was automatically imported from Jira and did not have any labels associated with it.
Condensed line Items on 3rd party invoices were unaffected, as were invoiced totals displayed within Aerion - only exports (PDF/XLSX/CSV) were affected.
The following time entries were affected and would not appear in an export or PDF linked to an invoice:
Time entries linked to a reference that was imported from Jira, without a label attached.
The following time entries would not have been affected, and would still show in exports as expected
Time entries without references
Time entries with references created via the Browser Extension, or otherwise not auto-imported from Jira
Time entries auto-imported from Jira with at least one Label defined in Jira.